[webkit-changes] [WebKit/WebKit] fc13b1: [Skia] Add Color operators to easily convert from/...

Carlos Garcia Campos noreply at github.com
Sun Feb 25 22:39:29 PST 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: fc13b190064d364d3046e56370ce5202826655fc
      https://github.com/WebKit/WebKit/commit/fc13b190064d364d3046e56370ce5202826655fc
  Author: Carlos Garcia Campos <cgarcia at igalia.com>
  Date:   2024-02-25 (Sun, 25 Feb 2024)

  Changed paths:
    M Source/WebCore/platform/SourcesSkia.txt
    M Source/WebCore/platform/graphics/Color.h
    A Source/WebCore/platform/graphics/skia/ColorSkia.cpp
    M Source/WebCore/platform/graphics/skia/GradientSkia.cpp
    M Source/WebCore/platform/graphics/skia/GraphicsContextSkia.cpp

  Log Message:
  -----------
  [Skia] Add Color operators to easily convert from/to SkColor and SkColor4f
https://bugs.webkit.org/show_bug.cgi?id=269978

Reviewed by Nikolas Zimmermann.

We avoid duplicated code and simplify the use of colors.

* Source/WebCore/platform/SourcesSkia.txt:
* Source/WebCore/platform/graphics/Color.h:
* Source/WebCore/platform/graphics/skia/ColorSkia.cpp: Added.
(WebCore::Color::Color):
(WebCore::Color::operator SkColor const):
(WebCore::Color::operator SkColor4f const):
* Source/WebCore/platform/graphics/skia/GradientSkia.cpp:
(WebCore::Gradient::shader):
* Source/WebCore/platform/graphics/skia/GraphicsContextSkia.cpp:
(WebCore::GraphicsContextSkia::createDropShadowFilterIfNeeded const):
(WebCore::GraphicsContextSkia::createFillPaint const):
(WebCore::GraphicsContextSkia::createStrokePaint const):

Canonical link: https://commits.webkit.org/275308@main



To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications


More information about the webkit-changes mailing list