[webkit-changes] [WebKit/WebKit] 619674: Add more fallback logic for the name of a browser ...

Brian Weinstein noreply at github.com
Fri Feb 23 11:14:44 PST 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 6196748e4b8469493d488992d5dd1f38e6312624
      https://github.com/WebKit/WebKit/commit/6196748e4b8469493d488992d5dd1f38e6312624
  Author: Brian Weinstein <bweinstein at apple.com>
  Date:   2024-02-23 (Fri, 23 Feb 2024)

  Changed paths:
    M Source/WebKit/UIProcess/Extensions/Cocoa/WebExtensionCocoa.mm
    M Source/WebKit/UIProcess/Extensions/Cocoa/WebExtensionCommandCocoa.mm

  Log Message:
  -----------
  Add more fallback logic for the name of a browser action keyboard shortcut
https://bugs.webkit.org/show_bug.cgi?id=269997
rdar://123455683

Reviewed by Timothy Hatcher.

This change:
1) Makes it so we don't crash if a command has an empty name or description
2) Falls back to the display name for _execute_browser_action if no action title is specified

* Source/WebKit/UIProcess/Extensions/Cocoa/WebExtensionCocoa.mm:
(WebKit::WebExtension::populateCommandsIfNeeded):
* Source/WebKit/UIProcess/Extensions/Cocoa/WebExtensionCommandCocoa.mm:
(+[_WKWebExtensionKeyCommand commandWithTitle:image:input:modifierFlags:handler:]):

Canonical link: https://commits.webkit.org/275248@main



To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications


More information about the webkit-changes mailing list