[webkit-changes] [WebKit/WebKit] bbcc01: [JSC] Rename MegamorphicCache's load related fields

Yusuke Suzuki noreply at github.com
Tue Feb 20 15:00:22 PST 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: bbcc016589702ba11cacd4fe32c235c3ebe72559
      https://github.com/WebKit/WebKit/commit/bbcc016589702ba11cacd4fe32c235c3ebe72559
  Author: Yusuke Suzuki <ysuzuki at apple.com>
  Date:   2024-02-20 (Tue, 20 Feb 2024)

  Changed paths:
    M Source/JavaScriptCore/jit/AssemblyHelpers.cpp
    M Source/JavaScriptCore/runtime/MegamorphicCache.cpp
    M Source/JavaScriptCore/runtime/MegamorphicCache.h

  Log Message:
  -----------
  [JSC] Rename MegamorphicCache's load related fields
https://bugs.webkit.org/show_bug.cgi?id=269811
rdar://123333247

Reviewed by Keith Miller and Michael Saboff.

Let's rename Load related MegamorphicCache fields to explicitly say "Load".
Previously, it didn't since MegamorphicCache implementation started with Load only.
And eventually it gets expanded.

* Source/JavaScriptCore/jit/AssemblyHelpers.cpp:
(JSC::AssemblyHelpers::loadMegamorphicProperty):
* Source/JavaScriptCore/runtime/MegamorphicCache.cpp:
(JSC::MegamorphicCache::age):
(JSC::MegamorphicCache::clearEntries):
* Source/JavaScriptCore/runtime/MegamorphicCache.h:
(JSC::MegamorphicCache::LoadEntry::offsetOfUid):
(JSC::MegamorphicCache::LoadEntry::offsetOfStructureID):
(JSC::MegamorphicCache::LoadEntry::offsetOfEpoch):
(JSC::MegamorphicCache::LoadEntry::offsetOfOffset):
(JSC::MegamorphicCache::LoadEntry::offsetOfHolder):
(JSC::MegamorphicCache::offsetOfLoadCachePrimaryEntries):
(JSC::MegamorphicCache::offsetOfLoadCacheSecondaryEntries):
(JSC::MegamorphicCache::initAsMiss):
(JSC::MegamorphicCache::initAsHit):
(JSC::MegamorphicCache::Entry::offsetOfUid): Deleted.
(JSC::MegamorphicCache::Entry::offsetOfStructureID): Deleted.
(JSC::MegamorphicCache::Entry::offsetOfEpoch): Deleted.
(JSC::MegamorphicCache::Entry::offsetOfOffset): Deleted.
(JSC::MegamorphicCache::Entry::offsetOfHolder): Deleted.
(JSC::MegamorphicCache::Entry::initAsMiss): Deleted.
(JSC::MegamorphicCache::Entry::initAsHit): Deleted.
(JSC::MegamorphicCache::offsetOfPrimaryEntries): Deleted.
(JSC::MegamorphicCache::offsetOfSecondaryEntries): Deleted.

Canonical link: https://commits.webkit.org/275073@main



To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications


More information about the webkit-changes mailing list