[webkit-changes] [WebKit/WebKit] 69fa6f: Minor HTMLFrameOwnerElement cleanup

Anne van Kesteren noreply at github.com
Thu Feb 1 05:13:29 PST 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 69fa6f6168e13a6a2b3b24f4b77ae2b0490b7dca
      https://github.com/WebKit/WebKit/commit/69fa6f6168e13a6a2b3b24f4b77ae2b0490b7dca
  Author: Anne van Kesteren <annevk at annevk.nl>
  Date:   2024-02-01 (Thu, 01 Feb 2024)

  Changed paths:
    M Source/WebCore/dom/Node.cpp
    M Source/WebCore/dom/Node.h
    M Source/WebCore/html/HTMLFrameOwnerElement.h
    M Source/WebCore/inspector/agents/InspectorDOMAgent.cpp
    M Source/WebCore/page/FocusController.cpp
    M Source/WebCore/page/SpatialNavigation.cpp
    M Source/WebCore/page/SpatialNavigation.h

  Log Message:
  -----------
  Minor HTMLFrameOwnerElement cleanup
https://bugs.webkit.org/show_bug.cgi?id=268453

Reviewed by Chris Dumez.

This makes the following changes:

- Move to dynamicDowncast<HTMLFrameOwnerElement> where applicable.
- Move to is<HTMLFrameOwnerElement> where applicable.
- Rename isFrameOwnerElement() to isHTMLFrameOwnerElement() for
  clarity.

* Source/WebCore/dom/Node.cpp:
(WebCore::showSubTreeAcrossFrame):
* Source/WebCore/dom/Node.h:
(WebCore::Node::isHTMLFrameOwnerElement const):
(WebCore::Node::isFrameOwnerElement const): Deleted.
* Source/WebCore/html/HTMLFrameOwnerElement.h:
(isType):
* Source/WebCore/inspector/agents/InspectorDOMAgent.cpp:
(WebCore::InspectorDOMAgent::unbind):
* Source/WebCore/page/FocusController.cpp:
(WebCore::FocusController::findFocusCandidateInContainer):
* Source/WebCore/page/SpatialNavigation.cpp:
(WebCore::frameOwnerElement):
* Source/WebCore/page/SpatialNavigation.h:
(WebCore::FocusCandidate::inScrollableContainer const):
(WebCore::FocusCandidate::isFrameOwnerElement const): Deleted.

Canonical link: https://commits.webkit.org/273901@main




More information about the webkit-changes mailing list