[webkit-changes] [WebKit/WebKit] 8f6576: [WebGPU] Rename vertex shaders in clamp pipelines ...

mwyrzykowski noreply at github.com
Wed Dec 11 15:03:49 PST 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 8f65768faa781a280fc64bd5a9220bed5f289394
      https://github.com/WebKit/WebKit/commit/8f65768faa781a280fc64bd5a9220bed5f289394
  Author: Mike Wyrzykowski <mwyrzykowski at apple.com>
  Date:   2024-12-11 (Wed, 11 Dec 2024)

  Changed paths:
    M Source/WebGPU/WebGPU/CommandEncoder.mm
    M Source/WebGPU/WebGPU/ComputePassEncoder.mm
    M Source/WebGPU/WebGPU/Device.mm

  Log Message:
  -----------
  [WebGPU] Rename vertex shaders in clamp pipelines to unique names
https://bugs.webkit.org/show_bug.cgi?id=281903
rdar://138398308

Reviewed by Cameron McCormack and Tadeu Zagallo.

Give better names to the custom vertex functions.

Also use call_once() because otherwise multiple threads could
attempt to create the function simultaneously.

* Source/WebGPU/WebGPU/CommandEncoder.mm:
(WebGPU::createSimplePso):
* Source/WebGPU/WebGPU/Device.mm:
(WebGPU::Device::copyIndexIndirectArgsPipeline):
* Source/WebGPU/WebGPU/ComputePassEncoder.mm:
(WebGPU::ComputePassEncoder::runPredispatchIndirectCallValidation):

Canonical link: https://commits.webkit.org/287698@main



To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications


More information about the webkit-changes mailing list