[webkit-changes] [WebKit/WebKit] 40ce17: Use naming conventions for Font IPC
Don Olmstead
noreply at github.com
Mon Apr 29 15:59:38 PDT 2024
Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 40ce17e8ec3287c304383c2641ca0e2e4a7bebf9
https://github.com/WebKit/WebKit/commit/40ce17e8ec3287c304383c2641ca0e2e4a7bebf9
Author: Don Olmstead <don.olmstead at sony.com>
Date: 2024-04-29 (Mon, 29 Apr 2024)
Changed paths:
M Source/WebCore/platform/graphics/FontPlatformData.h
M Source/WebCore/platform/graphics/coretext/FontPlatformDataCoreText.cpp
M Source/WebKit/Shared/Cocoa/WebCoreArgumentCodersCocoa.serialization.in
M Source/WebKit/Shared/WebCoreArgumentCoders.serialization.in
Log Message:
-----------
Use naming conventions for Font IPC
https://bugs.webkit.org/show_bug.cgi?id=273422
Reviewed by Chris Dumez.
Use `toIPCData` and `fromIPCData` when serializing `FontPlatformData`. This
conforms with the updated naming conventions.
Organize the code so other platforms can start generating serialization.
* Source/WebCore/platform/graphics/FontPlatformData.h:
* Source/WebCore/platform/graphics/coretext/FontPlatformDataCoreText.cpp:
(WebCore::FontPlatformData::fromIPCData):
(WebCore::FontPlatformData::toIPCData const):
(WebCore::FontPlatformData::tryMakeFontPlatformData): Deleted.
(WebCore::FontPlatformData::platformSerializationData const): Deleted.
* Source/WebKit/Shared/Cocoa/WebCoreArgumentCodersCocoa.serialization.in:
* Source/WebKit/Shared/WebCoreArgumentCoders.serialization.in:
Canonical link: https://commits.webkit.org/278132@main
To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications
More information about the webkit-changes
mailing list