[webkit-changes] [WebKit/WebKit] cfb200: [CSS Fonts] font-size-adjust adopts ValueType and ...

ChangSeok Oh noreply at github.com
Mon Oct 9 18:40:12 PDT 2023


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: cfb200931b4c0c03c4d00639c733ffb6b752016e
      https://github.com/WebKit/WebKit/commit/cfb200931b4c0c03c4d00639c733ffb6b752016e
  Author: ChangSeok Oh <changseok at webkit.org>
  Date:   2023-10-09 (Mon, 09 Oct 2023)

  Changed paths:
    M Source/WebCore/animation/CSSPropertyAnimation.cpp
    M Source/WebCore/css/ComputedStyleExtractor.cpp
    M Source/WebCore/platform/graphics/FontCascadeCache.h
    M Source/WebCore/platform/graphics/FontCascadeFonts.h
    M Source/WebCore/platform/graphics/FontSizeAdjust.h
    M Source/WebCore/style/StyleBuilderConverter.h

  Log Message:
  -----------
  [CSS Fonts] font-size-adjust adopts ValueType and isNone().
https://bugs.webkit.org/show_bug.cgi?id=262882

Reviewed by Tim Nguyen.

To improve code readability, this change replaces a boolean with an enum class,
which represents the from-font value type of FontSizeAdjust. In addition, this
patch changes the boolean operator of FontSizeAdjust to an explicit method name
called isNone() as a follow-up of 269041 at main [1].

[1] https://commits.webkit.org/269041@main

* Source/WebCore/animation/CSSPropertyAnimation.cpp:
* Source/WebCore/css/ComputedStyleExtractor.cpp:
(WebCore::fontSizeAdjustFromStyle):
(WebCore::fontShorthandValue):
* Source/WebCore/platform/graphics/FontCascadeCache.h:
(WebCore::FontDescriptionKey::FontDescriptionKey):
* Source/WebCore/platform/graphics/FontCascadeFonts.h:
(WebCore::FontCascadeFonts::primaryFont):
* Source/WebCore/platform/graphics/FontSizeAdjust.h:
(WebCore::FontSizeAdjust::isNone const):
(WebCore::FontSizeAdjust::isFromFont const):
(WebCore::add):
(WebCore::operator<<):
(WebCore::FontSizeAdjust::operator bool const): Deleted.
* Source/WebCore/style/StyleBuilderConverter.h:
(WebCore::Style::BuilderConverter::convertFontSizeAdjust):

Canonical link: https://commits.webkit.org/269124@main




More information about the webkit-changes mailing list