[webkit-changes] [WebKit/WebKit] 47696b: [UnifiedPDF] De-hoist "PDFView" coordinate convers...

Tim Horton noreply at github.com
Tue Nov 28 18:20:49 PST 2023


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 47696bacc0e06a2d1d0c63a716961b930f31f0b0
      https://github.com/WebKit/WebKit/commit/47696bacc0e06a2d1d0c63a716961b930f31f0b0
  Author: Tim Horton <thorton at apple.com>
  Date:   2023-11-28 (Tue, 28 Nov 2023)

  Changed paths:
    M Source/WebKit/WebProcess/Plugins/PDF/PDFPlugin.h
    M Source/WebKit/WebProcess/Plugins/PDF/PDFPlugin.mm
    M Source/WebKit/WebProcess/Plugins/PDF/PDFPluginBase.h
    M Source/WebKit/WebProcess/Plugins/PDF/PDFPluginBase.mm

  Log Message:
  -----------
  [UnifiedPDF] De-hoist "PDFView" coordinate conversion functions back to PDFPlugin
https://bugs.webkit.org/show_bug.cgi?id=265490
rdar://118906205

Reviewed by Wenson Hsieh and Simon Fraser.

When I hoisted these, I left a FIXME to make sure they make sense.
They don't. We don't have any Y flip in UnifiedPDFPlugin.
Move them back to PDFPlugin and add the "PluginToRootView" methods that we really needed.
Also rename frameForHUD to be clear about the coordinate space.

* Source/WebKit/WebProcess/Plugins/PDF/PDFPlugin.h:
* Source/WebKit/WebProcess/Plugins/PDF/PDFPlugin.mm:
(WebKit::PDFPlugin::convertFromPluginToPDFView const):
(WebKit::PDFPlugin::convertFromPDFViewToRootView const):
(WebKit::PDFPlugin::convertFromRootViewToPDFView const):
(WebKit::PDFPlugin::convertFromPDFViewToScreen const):
* Source/WebKit/WebProcess/Plugins/PDF/PDFPluginBase.h:
* Source/WebKit/WebProcess/Plugins/PDF/PDFPluginBase.mm:
(WebKit::PDFPluginBase::visibilityDidChange):
(WebKit::PDFPluginBase::convertFromRootViewToPlugin const):
(WebKit::PDFPluginBase::convertFromPluginToRootView const):
(WebKit::PDFPluginBase::updatePDFHUDLocation):
(WebKit::PDFPluginBase::frameForHUDInRootViewCoordinates const):
(WebKit::PDFPluginBase::convertFromPluginToPDFView const): Deleted.
(WebKit::PDFPluginBase::convertFromPDFViewToRootView const): Deleted.
(WebKit::PDFPluginBase::convertFromRootViewToPDFView const): Deleted.
(WebKit::PDFPluginBase::convertFromPDFViewToScreen const): Deleted.
(WebKit::PDFPluginBase::frameForHUD const): Deleted.

Canonical link: https://commits.webkit.org/271253@main




More information about the webkit-changes mailing list