[webkit-changes] [WebKit/WebKit] 7a87c1: [Curl] Replace CURLOPT_POSTFIELDSIZE with CURLOPT_...

Kenji Shukuwa noreply at github.com
Wed Jul 12 00:22:56 PDT 2023


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 7a87c11590a3f0bcce3721c8e3373ade6da32cdf
      https://github.com/WebKit/WebKit/commit/7a87c11590a3f0bcce3721c8e3373ade6da32cdf
  Author: Kenji Shukuwa <kenji.shukuwa at open-tec.co.jp>
  Date:   2023-07-12 (Wed, 12 Jul 2023)

  Changed paths:
    M Source/WebCore/platform/network/curl/CurlContext.cpp
    M Source/WebCore/platform/network/curl/CurlContext.h
    M Source/WebCore/platform/network/curl/CurlRequest.cpp

  Log Message:
  -----------
  [Curl] Replace CURLOPT_POSTFIELDSIZE with CURLOPT_POSTFIELDSIZE_LARGE
https://bugs.webkit.org/show_bug.cgi?id=259137

Reviewed by Fujii Hironori.

Two options are used to set post field size in CurlContext.cpp:
CURLOPT_POSTFIELDSIZE and CURLOPT_POSTFIELDSIZE_LARGE.
Unify these options to CURLOPT_POSTFIELDSIZE_LARGE for better readability.
Also, CURLOPT_INFILESIZE is unified to CURLOPT_INFILESIZE_LARGE.

* Source/WebCore/platform/network/curl/CurlContext.cpp:
(WebCore::CurlHandle::enableHttpPostRequest):
(WebCore::CurlHandle::setPostFieldSize):
(WebCore::CurlHandle::enableHttpPutRequest):
(WebCore::CurlHandle::setInFileSize):
(WebCore::CurlHandle::setPostFieldLarge): Deleted.
(WebCore::CurlHandle::setInFileSizeLarge): Deleted.
* Source/WebCore/platform/network/curl/CurlContext.h:
* Source/WebCore/platform/network/curl/CurlRequest.cpp:
(WebCore::CurlRequest::setupSendData):

Canonical link: https://commits.webkit.org/265987@main




More information about the webkit-changes mailing list