[webkit-changes] [WebKit/WebKit] b05ea8: [content-visibility] Rename effectiveSkipsContent ...

Rob Buis noreply at github.com
Fri Jul 7 12:19:50 PDT 2023


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: b05ea8885c728499936cab576ce3be7f0a2007c3
      https://github.com/WebKit/WebKit/commit/b05ea8885c728499936cab576ce3be7f0a2007c3
  Author: Rob Buis <rbuis at igalia.com>
  Date:   2023-07-07 (Fri, 07 Jul 2023)

  Changed paths:
    M Source/WebCore/rendering/RenderObject.cpp
    M Source/WebCore/rendering/style/RenderStyle.h
    M Source/WebCore/rendering/style/RenderStyleInlines.h
    M Source/WebCore/rendering/style/RenderStyleSetters.h
    M Source/WebCore/rendering/style/StyleRareInheritedData.cpp
    M Source/WebCore/rendering/style/StyleRareInheritedData.h
    M Source/WebCore/rendering/updating/RenderTreeUpdater.cpp
    M Source/WebCore/style/StyleAdjuster.cpp

  Log Message:
  -----------
  [content-visibility] Rename effectiveSkipsContent to effectiveSkippedContent
https://bugs.webkit.org/show_bug.cgi?id=258983

Reviewed by Tim Nguyen.

Rename effectiveSkipsContent to effectiveSkippedContent since effectiveSkipsContent
is correct for the root but in fact the flag is inherited down and so is misleading for
true skipped content.

* Source/WebCore/rendering/RenderObject.cpp:
(WebCore::RenderObject::isSkippedContent const):
* Source/WebCore/rendering/style/RenderStyle.h:
* Source/WebCore/rendering/style/RenderStyleInlines.h:
(WebCore::RenderStyle::effectiveSkippedContent const):
(WebCore::RenderStyle::effectiveSkipsContent const): Deleted.
* Source/WebCore/rendering/style/RenderStyleSetters.h:
(WebCore::RenderStyle::setEffectiveSkippedContent):
(WebCore::RenderStyle::setEffectiveSkipsContent): Deleted.
* Source/WebCore/rendering/style/StyleRareInheritedData.cpp:
(WebCore::StyleRareInheritedData::StyleRareInheritedData):
(WebCore::StyleRareInheritedData::operator== const):
* Source/WebCore/rendering/style/StyleRareInheritedData.h:
* Source/WebCore/rendering/updating/RenderTreeUpdater.cpp:
(WebCore::RenderTreeUpdater::updateRenderTree):
(WebCore::RenderTreeUpdater::updateElementRenderer):
* Source/WebCore/style/StyleAdjuster.cpp:
(WebCore::Style::Adjuster::adjust const):

Canonical link: https://commits.webkit.org/265858@main




More information about the webkit-changes mailing list