[webkit-changes] [WebKit/WebKit] b63e2e: Disambiguate Interpreter::execute() methods.

EWS noreply at github.com
Fri Jan 27 00:04:45 PST 2023


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: b63e2e2d251cc59a738bd4e68b742cba5e043ac2
      https://github.com/WebKit/WebKit/commit/b63e2e2d251cc59a738bd4e68b742cba5e043ac2
  Author: Mark Lam <mark.lam at apple.com>
  Date:   2023-01-27 (Fri, 27 Jan 2023)

  Changed paths:
    M Source/JavaScriptCore/debugger/DebuggerCallFrame.cpp
    M Source/JavaScriptCore/interpreter/CachedCall.h
    M Source/JavaScriptCore/interpreter/Interpreter.cpp
    M Source/JavaScriptCore/interpreter/Interpreter.h
    M Source/JavaScriptCore/interpreter/InterpreterInlines.h
    M Source/JavaScriptCore/runtime/JSGlobalObjectFunctions.cpp
    M Source/JavaScriptCore/runtime/ShadowRealmPrototype.cpp

  Log Message:
  -----------
  Disambiguate Interpreter::execute() methods.
https://bugs.webkit.org/show_bug.cgi?id=251249
<rdar://problem/104730730>

Reviewed by Yusuke Suzuki.

Most Interpreter execute methods already have unique names e.g. executeProgram, executeCall,
etc.  The only 2 that are still not disambiguated this way are for eval and cached calls.
Rename these to executeEval and executeCachedCall so that they are more easily grep'able.

* Source/JavaScriptCore/debugger/DebuggerCallFrame.cpp:
(JSC::DebuggerCallFrame::evaluateWithScopeExtension):
* Source/JavaScriptCore/interpreter/CachedCall.h:
(JSC::CachedCall::call):
* Source/JavaScriptCore/interpreter/Interpreter.cpp:
(JSC::eval):
(JSC::Interpreter::executeEval):
(JSC::Interpreter::execute): Deleted.
* Source/JavaScriptCore/interpreter/Interpreter.h:
* Source/JavaScriptCore/interpreter/InterpreterInlines.h:
(JSC::Interpreter::executeCachedCall):
(JSC::Interpreter::execute): Deleted.
* Source/JavaScriptCore/runtime/JSGlobalObjectFunctions.cpp:
(JSC::JSC_DEFINE_HOST_FUNCTION):
* Source/JavaScriptCore/runtime/ShadowRealmPrototype.cpp:
(JSC::JSC_DEFINE_HOST_FUNCTION):

Canonical link: https://commits.webkit.org/259470@main




More information about the webkit-changes mailing list