[webkit-changes] [WebKit/WebKit] dcd501: Rename SubimageCacheWithTimer to CGSubimageCacheWi...

Said Abou-Hallawa noreply at github.com
Fri Feb 3 07:44:19 PST 2023


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: dcd501fb2a549c0ef50a22553f4463289268c2c0
      https://github.com/WebKit/WebKit/commit/dcd501fb2a549c0ef50a22553f4463289268c2c0
  Author: Said Abou-Hallawa <said at apple.com>
  Date:   2023-02-03 (Fri, 03 Feb 2023)

  Changed paths:
    M Source/WebCore/PlatformAppleWin.cmake
    M Source/WebCore/PlatformMac.cmake
    M Source/WebCore/SourcesCocoa.txt
    M Source/WebCore/WebCore.xcodeproj/project.pbxproj
    M Source/WebCore/page/cocoa/MemoryReleaseCocoa.mm
    A Source/WebCore/platform/graphics/cg/CGSubimageCacheWithTimer.cpp
    A Source/WebCore/platform/graphics/cg/CGSubimageCacheWithTimer.h
    M Source/WebCore/platform/graphics/cg/GraphicsContextCG.cpp
    M Source/WebCore/platform/graphics/cg/NativeImageCG.cpp
    R Source/WebCore/platform/graphics/cg/SubimageCacheWithTimer.cpp
    R Source/WebCore/platform/graphics/cg/SubimageCacheWithTimer.h

  Log Message:
  -----------
  Rename SubimageCacheWithTimer to CGSubimageCacheWithTimer
https://bugs.webkit.org/show_bug.cgi?id=251641
rdar://104980275

Reviewed by Simon Fraser.

Since SubimageCacheWithTimer caches sub images of a CGImage only, rename it
CGSubimageCacheWithTimer. Then we can use CachedSubimage for caching a sub image
of an Image.

* Source/WebCore/PlatformAppleWin.cmake:
* Source/WebCore/PlatformMac.cmake:
* Source/WebCore/SourcesCocoa.txt:
* Source/WebCore/WebCore.xcodeproj/project.pbxproj:
* Source/WebCore/page/cocoa/MemoryReleaseCocoa.mm:
(WebCore::platformReleaseMemory):
(WebCore::platformReleaseGraphicsMemory):
* Source/WebCore/platform/graphics/cg/CGSubimageCacheWithTimer.cpp: Renamed from Source/WebCore/platform/graphics/cg/SubimageCacheWithTimer.cpp.
(WebCore::CGSubimageCacheWithTimer::getSubimage):
(WebCore::CGSubimageCacheWithTimer::clearImage):
(WebCore::CGSubimageCacheWithTimer::clear):
(WebCore::CGSubimageRequest::CGSubimageRequest):
(WebCore::CGSubimageCacheAdder::hash):
(WebCore::CGSubimageCacheAdder::equal):
(WebCore::CGSubimageCacheAdder::translate):
(WebCore::CGSubimageCacheWithTimer::CGSubimageCacheWithTimer):
(WebCore::CGSubimageCacheWithTimer::pruneCacheTimerFired):
(WebCore::CGSubimageCacheWithTimer::prune):
(WebCore::CGSubimageCacheWithTimer::subimage):
(WebCore::CGSubimageCacheWithTimer::clearImageAndSubimages):
(WebCore::CGSubimageCacheWithTimer::clearAll):
(WebCore::CGSubimageCacheWithTimer::subimageCache):
(WebCore::CGSubimageCacheWithTimer::subimageCacheExists):
* Source/WebCore/platform/graphics/cg/CGSubimageCacheWithTimer.h: Renamed from Source/WebCore/platform/graphics/cg/SubimageCacheWithTimer.h.
(WebCore::CGSubimageCacheWithTimer::CacheEntryTraits::isEmptyValue):
(WebCore::CGSubimageCacheWithTimer::CacheEntryTraits::constructDeletedValue):
(WebCore::CGSubimageCacheWithTimer::CacheEntryTraits::isDeletedValue):
(WebCore::CGSubimageCacheWithTimer::CacheHash::hash):
(WebCore::CGSubimageCacheWithTimer::CacheHash::equal):
* Source/WebCore/platform/graphics/cg/GraphicsContextCG.cpp:
(WebCore::GraphicsContextCG::drawNativeImage):
* Source/WebCore/platform/graphics/cg/NativeImageCG.cpp:
(WebCore::NativeImage::clearSubimages):

Canonical link: https://commits.webkit.org/259817@main




More information about the webkit-changes mailing list