[webkit-changes] [WebKit/WebKit] b8b07e: Rename `renderRect` to make it clear it's an absol...

Simon Fraser noreply at github.com
Fri Dec 15 17:49:45 PST 2023


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: b8b07e7d490fedfd868d1e7d09d7361e4ebf06ca
      https://github.com/WebKit/WebKit/commit/b8b07e7d490fedfd868d1e7d09d7361e4ebf06ca
  Author: Simon Fraser <simon.fraser at apple.com>
  Date:   2023-12-15 (Fri, 15 Dec 2023)

  Changed paths:
    M Source/WebCore/dom/Node.cpp
    M Source/WebCore/dom/Node.h
    M Source/WebCore/html/HTMLAttachmentElement.cpp
    M Source/WebKit/UIProcess/RemoteLayerTree/mac/RemoteLayerTreeDrawingAreaProxyMac.mm
    M Source/WebKit/UIProcess/ViewGestureController.h
    M Source/WebKit/UIProcess/ios/SmartMagnificationController.mm
    M Source/WebKit/UIProcess/mac/ViewGestureControllerMac.mm
    M Source/WebKit/WebProcess/InjectedBundle/DOM/InjectedBundleNodeHandle.cpp
    M Source/WebKit/WebProcess/InjectedBundle/DOM/InjectedBundleNodeHandle.h
    M Source/WebKit/WebProcess/WebPage/ViewGestureGeometryCollector.cpp
    M Source/WebKit/WebProcess/WebPage/ViewGestureGeometryCollector.h
    M Source/WebKit/WebProcess/WebPage/ios/FindControllerIOS.mm
    M Source/WebKit/WebProcess/WebPage/ios/WebPageIOS.mm
    M Source/WebKitLegacy/mac/DOM/WebDOMOperations.mm

  Log Message:
  -----------
  Rename `renderRect` to make it clear it's an absolute rect
https://bugs.webkit.org/show_bug.cgi?id=266496
rdar://119730738

Reviewed by Alan Baradlay.

Rename Node's `renderRect` and `pixelSnappedRenderRect` functions to refer to absolute coordinates, since
that's what they are. Propagate this rename though view gesture geometry code, and the other callers.

* Source/WebCore/dom/Node.cpp:
(WebCore::Node::absoluteBoundingRect):
(WebCore::Node::renderRect): Deleted.
* Source/WebCore/dom/Node.h:
(WebCore::Node::pixelSnappedAbsoluteBoundingRect):
(WebCore::Node::pixelSnappedRenderRect): Deleted.
* Source/WebCore/html/HTMLAttachmentElement.cpp:
(WebCore::HTMLAttachmentElement::saveButtonClientRect const):
* Source/WebKit/UIProcess/RemoteLayerTree/mac/RemoteLayerTreeDrawingAreaProxyMac.mm:
(WebKit::RemoteLayerTreeDrawingAreaProxyMac::commitTransientZoom):
* Source/WebKit/UIProcess/ViewGestureController.h:
* Source/WebKit/UIProcess/ios/SmartMagnificationController.mm:
(WebKit::SmartMagnificationController::didCollectGeometryForSmartMagnificationGesture):
* Source/WebKit/UIProcess/mac/ViewGestureControllerMac.mm:
(WebKit::ViewGestureController::didCollectGeometryForSmartMagnificationGesture):
* Source/WebKit/WebProcess/InjectedBundle/DOM/InjectedBundleNodeHandle.cpp:
(WebKit::InjectedBundleNodeHandle::absoluteBoundingRect):
(WebKit::InjectedBundleNodeHandle::renderRect): Deleted.
* Source/WebKit/WebProcess/InjectedBundle/DOM/InjectedBundleNodeHandle.h:
* Source/WebKit/WebProcess/WebPage/ViewGestureGeometryCollector.cpp:
(WebKit::ViewGestureGeometryCollector::dispatchDidCollectGeometryForSmartMagnificationGesture):
(WebKit::ViewGestureGeometryCollector::collectGeometryForSmartMagnificationGesture):
(WebKit::ViewGestureGeometryCollector::computeZoomInformationForNode):
* Source/WebKit/WebProcess/WebPage/ViewGestureGeometryCollector.h:
* Source/WebKit/WebProcess/WebPage/ios/FindControllerIOS.mm:
(WebKit::FindController::updateFindIndicator):
* Source/WebKit/WebProcess/WebPage/ios/WebPageIOS.mm:
(WebKit::WebPage::potentialTapAtPosition):
* Source/WebKitLegacy/mac/DOM/WebDOMOperations.mm:
(-[DOMNode _renderRect:]):

Canonical link: https://commits.webkit.org/272154@main




More information about the webkit-changes mailing list