[webkit-changes] [WebKit/WebKit] ef40ef: Use FlexLineStates as a type alias for Vector<Line...
Sammy Gill
noreply at github.com
Fri Aug 11 19:33:36 PDT 2023
Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: ef40ef0a52fe2468e1bf8d276b96f5a1b8085d41
https://github.com/WebKit/WebKit/commit/ef40ef0a52fe2468e1bf8d276b96f5a1b8085d41
Author: Sammy Gill <sammy.gill at apple.com>
Date: 2023-08-11 (Fri, 11 Aug 2023)
Changed paths:
M Source/WebCore/rendering/RenderFlexibleBox.cpp
M Source/WebCore/rendering/RenderFlexibleBox.h
Log Message:
-----------
Use FlexLineStates as a type alias for Vector<LineState>.
https://bugs.webkit.org/show_bug.cgi?id=260108
rdar://problem/113778236
Reviewed by Tim Nguyen.
The new alias helps with readability throughtout the code. Also renamed
the "linesState," variables to "lineStates," since the former was a bit
confusing to read given the type.
* Source/WebCore/rendering/RenderFlexibleBox.cpp:
(WebCore::RenderFlexibleBox::repositionLogicalHeightDependentFlexItems):
(WebCore::RenderFlexibleBox::layoutFlexItems):
(WebCore::RenderFlexibleBox::layoutAndPlaceChildren):
(WebCore::RenderFlexibleBox::alignFlexLines):
(WebCore::RenderFlexibleBox::alignChildren):
(WebCore::RenderFlexibleBox::flipForRightToLeftColumn):
(WebCore::RenderFlexibleBox::flipForWrapReverse):
* Source/WebCore/rendering/RenderFlexibleBox.h:
Canonical link: https://commits.webkit.org/266843@main
More information about the webkit-changes
mailing list