[webkit-changes] [WebKit/WebKit] d6b7b7: Rename RTCEncoderIdentifier to VideoEncoderIdentifier

youennf noreply at github.com
Tue Sep 27 04:12:52 PDT 2022


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: d6b7b72eeedaa699918636aed244f532fb1c9a9d
      https://github.com/WebKit/WebKit/commit/d6b7b72eeedaa699918636aed244f532fb1c9a9d
  Author: Youenn Fablet <youennf at gmail.com>
  Date:   2022-09-27 (Tue, 27 Sep 2022)

  Changed paths:
    M Source/WebKit/GPUProcess/webrtc/LibWebRTCCodecsProxy.h
    M Source/WebKit/GPUProcess/webrtc/LibWebRTCCodecsProxy.messages.in
    M Source/WebKit/GPUProcess/webrtc/LibWebRTCCodecsProxy.mm
    M Source/WebKit/Scripts/webkit/messages.py
    M Source/WebKit/Scripts/webkit/tests/MessageArgumentDescriptions.cpp
    M Source/WebKit/WebKit.xcodeproj/project.pbxproj
    M Source/WebKit/WebProcess/GPU/webrtc/LibWebRTCCodecs.cpp
    M Source/WebKit/WebProcess/GPU/webrtc/LibWebRTCCodecs.h
    M Source/WebKit/WebProcess/GPU/webrtc/LibWebRTCCodecs.messages.in
    R Source/WebKit/WebProcess/GPU/webrtc/RTCDecoderIdentifier.h
    R Source/WebKit/WebProcess/GPU/webrtc/RTCEncoderIdentifier.h
    A Source/WebKit/WebProcess/GPU/webrtc/VideoDecoderIdentifier.h
    A Source/WebKit/WebProcess/GPU/webrtc/VideoEncoderIdentifier.h

  Log Message:
  -----------
  Rename RTCEncoderIdentifier to VideoEncoderIdentifier
https://bugs.webkit.org/show_bug.cgi?id=245666
rdar://problem/100402861

Reviewed by Eric Carlson.

We also rename RTCDecoderIdentifier in VideoDecoderIdentifier.

* Source/WebKit/GPUProcess/webrtc/LibWebRTCCodecsProxy.h:
* Source/WebKit/GPUProcess/webrtc/LibWebRTCCodecsProxy.messages.in:
* Source/WebKit/GPUProcess/webrtc/LibWebRTCCodecsProxy.mm:
(WebKit::LibWebRTCCodecsProxy::createDecoderCallback):
(WebKit::LibWebRTCCodecsProxy::createH264Decoder):
(WebKit::LibWebRTCCodecsProxy::createH265Decoder):
(WebKit::LibWebRTCCodecsProxy::createVP9Decoder):
(WebKit::LibWebRTCCodecsProxy::releaseDecoder):
(WebKit::LibWebRTCCodecsProxy::createEncoder):
(WebKit::LibWebRTCCodecsProxy::releaseEncoder):
(WebKit::LibWebRTCCodecsProxy::initializeEncoder):
(WebKit::LibWebRTCCodecsProxy::findEncoder):
(WebKit::LibWebRTCCodecsProxy::encodeFrame):
(WebKit::LibWebRTCCodecsProxy::setEncodeRates):
(WebKit::LibWebRTCCodecsProxy::setSharedVideoFrameSemaphore):
(WebKit::LibWebRTCCodecsProxy::setSharedVideoFrameMemory):
* Source/WebKit/Scripts/webkit/messages.py:
(serialized_identifiers):
* Source/WebKit/Scripts/webkit/tests/MessageArgumentDescriptions.cpp:
(IPC::serializedIdentifiers):
* Source/WebKit/WebKit.xcodeproj/project.pbxproj:
* Source/WebKit/WebProcess/GPU/webrtc/LibWebRTCCodecs.cpp:
(WebKit::LibWebRTCCodecs::createDecoder):
(WebKit::LibWebRTCCodecs::failedDecoding):
(WebKit::LibWebRTCCodecs::completedDecoding):
(WebKit::LibWebRTCCodecs::completedDecodingCV):
(WebKit::LibWebRTCCodecs::createEncoder):
(WebKit::LibWebRTCCodecs::completedEncoding):
* Source/WebKit/WebProcess/GPU/webrtc/LibWebRTCCodecs.h:
* Source/WebKit/WebProcess/GPU/webrtc/LibWebRTCCodecs.messages.in:
* Source/WebKit/WebProcess/GPU/webrtc/VideoDecoderIdentifier.h: Renamed from Source/WebKit/WebProcess/GPU/webrtc/RTCDecoderIdentifier.h.
* Source/WebKit/WebProcess/GPU/webrtc/VideoEncoderIdentifier.h: Renamed from Source/WebKit/WebProcess/GPU/webrtc/RTCEncoderIdentifier.h.

Canonical link: https://commits.webkit.org/254903@main




More information about the webkit-changes mailing list