[webkit-changes] [WebKit/WebKit] 025747: Rename SVGSVGElement::currentViewportSize() -> cur...

Nikolas Zimmermann noreply at github.com
Thu Oct 6 08:14:30 PDT 2022


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 0257470cd80158d053c210da65dca09b6d256b24
      https://github.com/WebKit/WebKit/commit/0257470cd80158d053c210da65dca09b6d256b24
  Author: Nikolas Zimmermann <nzimmermann at igalia.com>
  Date:   2022-10-06 (Thu, 06 Oct 2022)

  Changed paths:
    M Source/WebCore/svg/SVGLengthContext.cpp
    M Source/WebCore/svg/SVGSVGElement.cpp
    M Source/WebCore/svg/SVGSVGElement.h
    M Source/WebCore/svg/graphics/SVGImage.cpp

  Log Message:
  -----------
  Rename SVGSVGElement::currentViewportSize() -> currentViewportSizeExcludingZoom() for clarity
https://bugs.webkit.org/show_bug.cgi?id=246016

Reviewed by Alejandro G. Castro.

SVGSVGElement::currentViewportSize() needs to exclude the 'zoom' induced scaling.
Rename the function to currentViewportSizeExcludingZoom() for clarity.

* Source/WebCore/svg/SVGLengthContext.cpp:
(WebCore::SVGLengthContext::computeViewportSize const):
* Source/WebCore/svg/SVGSVGElement.cpp:
(WebCore::SVGSVGElement::localCoordinateSpaceTransform const):
(WebCore::SVGSVGElement::currentViewportSizeExcludingZoom const):
(WebCore::SVGSVGElement::currentViewportSize const): Deleted.
* Source/WebCore/svg/SVGSVGElement.h:
* Source/WebCore/svg/graphics/SVGImage.cpp:
(WebCore::SVGImage::containerSize const):

Canonical link: https://commits.webkit.org/255221@main




More information about the webkit-changes mailing list