[webkit-changes] [WebKit/WebKit] b8989c: Rename FormNamedItem to FormAssociatedElement
Ryosuke Niwa
noreply at github.com
Mon Nov 14 16:14:41 PST 2022
Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: b8989c738ff49825b179917831a0e8607ef039b4
https://github.com/WebKit/WebKit/commit/b8989c738ff49825b179917831a0e8607ef039b4
Author: Ryosuke Niwa <rniwa at webkit.org>
Date: 2022-11-14 (Mon, 14 Nov 2022)
Changed paths:
M Source/WebCore/Headers.cmake
M Source/WebCore/WebCore.xcodeproj/project.pbxproj
A Source/WebCore/html/FormAssociatedElement.h
M Source/WebCore/html/FormListedElement.h
R Source/WebCore/html/FormNamedItem.h
M Source/WebCore/html/HTMLElement.cpp
M Source/WebCore/html/HTMLElement.h
M Source/WebCore/html/HTMLFormControlElement.h
M Source/WebCore/html/HTMLFormElement.cpp
M Source/WebCore/html/HTMLFormElement.h
M Source/WebCore/html/HTMLImageElement.h
M Source/WebCore/html/HTMLObjectElement.h
Log Message:
-----------
Rename FormNamedItem to FormAssociatedElement
https://bugs.webkit.org/show_bug.cgi?id=247912
Reviewed by Chris Dumez.
Renamed FormNamedItem to FormAssociatedElement since it maps to the concept of the same name
in the HTML5 specification: https://html.spec.whatwg.org/multipage/forms.html#form-associated-element
* Source/WebCore/Headers.cmake:
* Source/WebCore/WebCore.xcodeproj/project.pbxproj:
* Source/WebCore/html/FormAssociatedElement.h: Renamed from Source/WebCore/html/FormNamedItem.h.
(WebCore::FormAssociatedElement::ref):
(WebCore::FormAssociatedElement::deref):
* Source/WebCore/html/FormListedElement.h:
* Source/WebCore/html/HTMLElement.cpp:
(WebCore::HTMLElement::asFormAssociatedElement):
(WebCore::HTMLElement::asFormNamedItem): Deleted.
* Source/WebCore/html/HTMLElement.h:
* Source/WebCore/html/HTMLFormControlElement.h:
* Source/WebCore/html/HTMLFormElement.cpp:
(WebCore::HTMLFormElement::assertItemCanBeInPastNamesMap const):
(WebCore::HTMLFormElement::elementFromPastNamesMap const):
(WebCore::HTMLFormElement::addToPastNamesMap):
(WebCore::HTMLFormElement::removeFromPastNamesMap):
(WebCore::HTMLFormElement::namedElements):
* Source/WebCore/html/HTMLFormElement.h:
* Source/WebCore/html/HTMLImageElement.h:
* Source/WebCore/html/HTMLObjectElement.h:
Canonical link: https://commits.webkit.org/256678@main
More information about the webkit-changes
mailing list