[webkit-changes] [WebKit/WebKit] 5bfe4c: Rename HAVE(ACCESSIBILITY_ANIMATED_IMAGE_CONTROL) ...

Tyler Wilcock noreply at github.com
Sun Dec 4 13:34:01 PST 2022


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 5bfe4c6223b7e9629389d83f19fe04bf9f6110a8
      https://github.com/WebKit/WebKit/commit/5bfe4c6223b7e9629389d83f19fe04bf9f6110a8
  Author: Tyler Wilcock <tyler_w at apple.com>
  Date:   2022-12-04 (Sun, 04 Dec 2022)

  Changed paths:
    M LayoutTests/TestExpectations
    M LayoutTests/platform/mac/TestExpectations
    M Source/WTF/Scripts/Preferences/WebPreferencesExperimental.yaml
    M Source/WTF/wtf/PlatformEnable.h
    M Source/WTF/wtf/PlatformHave.h
    M Source/WebCore/html/HTMLImageElement.cpp
    M Source/WebCore/html/HTMLImageElement.h
    M Source/WebCore/page/ContextMenuController.cpp
    M Source/WebCore/page/Page.cpp
    M Source/WebCore/page/Page.h
    M Source/WebCore/page/SettingsBase.cpp
    M Source/WebCore/page/SettingsBase.h
    M Source/WebCore/testing/Internals.cpp
    M Source/WebCore/testing/Internals.idl
    M Source/WebKit/UIProcess/Cocoa/WebProcessPoolCocoa.mm
    M Source/WebKit/WebProcess/WebPage/WebPage.cpp
    M Source/WebKit/WebProcess/WebPage/WebPage.h
    M Source/WebKit/WebProcess/cocoa/WebProcessCocoa.mm

  Log Message:
  -----------
  Rename HAVE(ACCESSIBILITY_ANIMATED_IMAGE_CONTROL) to ENABLE(ACCESSIBILITY_ANIMATION_CONTROL) and use it in more places
https://bugs.webkit.org/show_bug.cgi?id=248545
rdar://102823518

Reviewed by Chris Fleizach.

We need to rename this flag to ENABLE(...) because certain Internals methods should be compiled
conditionally based on its state, and HAVE conditionals are not supported by our IDL codegen script.
Also, in general we should be using this flag in more places, which this patch accomplishes.

* Source/WTF/Scripts/Preferences/WebPreferencesExperimental.yaml:
* Source/WTF/wtf/PlatformEnable.h:
* Source/WTF/wtf/PlatformHave.h:
* Source/WebCore/html/HTMLImageElement.cpp:
(WebCore::HTMLImageElement::setAllowsAnimation):
Don't allow this function to do anything if the ImageAnimationControlEnabled
feature is disabled.
* Source/WebCore/html/HTMLImageElement.h:
* Source/WebCore/page/ContextMenuController.cpp:
(WebCore::ContextMenuController::populate):
* Source/WebCore/page/Page.cpp:
(WebCore::Page::setImageAnimationEnabled):
Don't allow this function to do anything if the ImageAnimationControlEnabled
feature is disabled.
* Source/WebCore/page/Page.h:
* Source/WebCore/page/SettingsBase.cpp:
(WebCore::SettingsBase::setImageAnimationControlEnabledChanged): Deleted.
* Source/WebCore/page/SettingsBase.h:
* Source/WebCore/testing/Internals.cpp:
* Source/WebCore/testing/Internals.idl:
* Source/WebKit/UIProcess/Cocoa/WebProcessPoolCocoa.mm:
(WebKit::accessibilityPreferences):
(WebKit::WebProcessPool::registerNotificationObservers):
* Source/WebKit/WebProcess/WebPage/WebPage.cpp:
(WebKit::WebPage::updateImageAnimationEnabled):
* Source/WebKit/WebProcess/WebPage/WebPage.h:
* Source/WebKit/WebProcess/cocoa/WebProcessCocoa.mm:
(WebKit::WebProcess::accessibilityPreferencesDidChange):
* LayoutTests/TestExpectations:
* LayoutTests/platform/mac/TestExpectations:
Skip tests:
  - fast/images/animations-resume-from-last-displayed-frame.html
  - fast/images/individual-animation-toggle.html
  - fast/images/page-wide-animation-toggle.html
  - fast/images/pagewide-play-pause-animateTransform-svg-animation.html
  - fast/images/pagewide-play-pause-offscreen-animations.html
  - fast/images/mac/play-all-pause-all-animations-context-menu-items.html
Because the implementation required for them to pass is now properly
gated behind ENABLE(ACCESSIBILITY_ANIMATION_CONTROL). They are
re-enabled in rdar://102830993.

Canonical link: https://commits.webkit.org/257362@main




More information about the webkit-changes mailing list