[webkit-changes] [31048] trunk/JavaScriptCore

Eric Seidel eric at webkit.org
Fri Mar 14 09:16:06 PDT 2008


r=me on adding the #if guards.  Otherwise I'll do it myself when I
find time today @ work.

-eric

On Fri, Mar 14, 2008 at 4:45 AM, Alexey Proskuryakov <ap at webkit.org> wrote:
>
>
>   FWIW, including sys/time.h is protected with an ifdef elsewhere, so this
> change may cause problems for some platforms.
>
>
> #if HAVE(SYS_TIME_H)
> #include <sys/time.h>
> #endif
>
> On Mar 14, 2008, at 6:43 AM, eric at webkit.org wrote:
>
> Revision31048Authoreric at webkit.orgDate2008-03-13 20:43:55 -0700 (Thu, 13 Mar
> 2008)
> Log Message Reviewed by eseidel. Landed by eseidel
>
>  * pcre/pcre_exec.cpp: Fix misnamed variable, allowing -DDEBUG build
>  to succeed.
>  * wtf/ThreadingPthreads.cpp: #include <sys/time.h> for gettimeofday
>  in non-pch build.
> Modified Paths
> trunk/JavaScriptCore/ChangeLog
> trunk/JavaScriptCore/pcre/pcre_exec.cpp
> trunk/JavaScriptCore/wtf/ThreadingPthreads.cpp
> Diff
> Modified: trunk/JavaScriptCore/ChangeLog (31047 => 31048)---
> trunk/JavaScriptCore/ChangeLog 2008-03-14 03:07:17 UTC (rev 31047)
> +++ trunk/JavaScriptCore/ChangeLog 2008-03-14 03:43:55 UTC (rev 31048)
> @@ -1,3 +1,12 @@
> +2008-03-13 Mark Mentovai <mark at moxienet.com>
> +
> + Reviewed by eseidel. Landed by eseidel
> +
> + * pcre/pcre_exec.cpp: Fix misnamed variable, allowing -DDEBUG build
> + to succeed.
> + * wtf/ThreadingPthreads.cpp: #include <sys/time.h> for gettimeofday
> + in non-pch build.
> +
>  2008-03-13 Steve Falkenburg <sfalken at apple.com>
>
>  PGO build fixes.
>
>
> Modified: trunk/JavaScriptCore/pcre/pcre_exec.cpp (31047 => 31048)---
> trunk/JavaScriptCore/pcre/pcre_exec.cpp 2008-03-14 03:07:17 UTC (rev 31047)
> +++ trunk/JavaScriptCore/pcre/pcre_exec.cpp 2008-03-14 03:43:55 UTC (rev
> 31048)
> @@ -2024,7 +2024,7 @@
>
>  if (returnCode != 1) {
>  ASSERT(returnCode == JSRegExpErrorHitLimit || returnCode ==
> JSRegExpErrorNoMemory);
> - DPRINTF((">>>> error: returning %d\n", rc));
> + DPRINTF((">>>> error: returning %d\n", returnCode));
>  return returnCode;
>  }
>
> @@ -2052,7 +2052,7 @@
>  offsets[1] = matchBlock.endMatchPtr - matchBlock.startSubject;
>  }
>
> - DPRINTF((">>>> returning %d\n", rc));
> + DPRINTF((">>>> returning %d\n", returnCode));
>  return returnCode;
>  } while (startMatch <= endSubject);
>
>
>
> Modified: trunk/JavaScriptCore/wtf/ThreadingPthreads.cpp (31047 => 31048)---
> trunk/JavaScriptCore/wtf/ThreadingPthreads.cpp 2008-03-14 03:07:17 UTC (rev
> 31047)
> +++ trunk/JavaScriptCore/wtf/ThreadingPthreads.cpp 2008-03-14 03:43:55 UTC
> (rev 31048)
> @@ -32,7 +32,7 @@
>  #include <wtf/HashMap.h>
>
>  #include <errno.h>
> -#include <time.h>
> +#include <sys/time.h>
>
>  namespace WTF {
>
>
> _______________________________________________
> webkit-changes mailing list
> webkit-changes at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo/webkit-changes
>
>
> - WBR, Alexey Proskuryakov
>
>


More information about the webkit-changes mailing list