<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><br class=""><div><blockquote type="cite" class=""><div class="">On Jan 5, 2017, at 9:37 AM, Brady Eidson &lt;<a href="mailto:beidson@apple.com" class="">beidson@apple.com</a>&gt; wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="Content-Type" content="text/html charset=utf-8" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><br class=""><div class=""><blockquote type="cite" class=""><div class="">On Jan 5, 2017, at 12:48 AM, Yusuke SUZUKI &lt;<a href="mailto:utatane.tea@gmail.com" class="">utatane.tea@gmail.com</a>&gt; wrote:</div><br class="Apple-interchange-newline"><div class=""><div dir="ltr" class=""><div class="gmail_extra"><div class="gmail_quote">On Thu, Jan 5, 2017 at 5:43 PM, Darin Adler <span dir="ltr" class="">&lt;<a href="mailto:darin@apple.com" target="_blank" class="">darin@apple.com</a>&gt;</span> wrote:<br class=""><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">I understand the appeal of “org.webkit” and structured names but personally I would prefer to read names that look like titles and are made up of words with spaces, like these:<br class="">
<br class="">
“WebKit: Image Decoder”, rather than “org.webkit.ImageDecoder”.<br class="">
“WebKit: JavaScript DFG Compiler” rather than “org.webkit.jsc.DFGCompiler”.<br class="">
<br class="">
Not sure how well that would generalize to all the different names.<br class="">
<br class="">
I like the idea of having a smart way of automatically making a shorter name for the platforms that have shorter length limits.<br class=""></blockquote><div class=""><br class=""></div><div class="">One interesting idea I've come up with is that,</div><div class=""><br class=""></div><div class="">1. specifying "org.webkit.ImageDecoder"</div><div class="">2. In Linux, we just use "ImageDecoder" part.</div><div class="">3. In macOS port, we automatically convert it to "WebKit: Image Decoder”</div></div></div></div></div></blockquote><div class=""><br class=""></div><div class=""><div class="">Why do we specify “org.webkit.ImageDecoder” if only the “ImageDecoder” part is ever going to be used?</div></div><div class="">Is that because Windows could use “org.webkit.”?</div></div></div></div></blockquote><div><br class=""></div><div>What about if you just specify "Image Decoder" and we automatically convert that to either "ImageDecoder" or "WebKit: Image Decoder" based on platform thread name limits? Is there any case where we want a prefix other than "WebKit: "?</div><div><br class=""></div><div>&nbsp;- Maciej</div><br class=""><blockquote type="cite" class=""><div class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><div class=""><div class=""><br class=""></div><div class="">Again, back to Darin’s point, I don’t see any particular value in ever seeing “org.webkit.”</div><div class=""><br class=""></div><div class="">Additionally, the way this proposal treats “ImageDecoder” as multiple words, presumably separated on case-change, is problematic.</div><div class=""><br class=""></div><div class="">e.g. “IndexedDatabaseServer” would expand to “Indexed Database Server”, different from today.</div><div class="">e.g. “IndexedDBServer”, which is probably what this should be called, would expand to “Indexed D B Server"</div><div class="">e.g. “GCController” would expand to “G C Controller”</div><div class=""><br class=""></div><div class="">—</div><div class=""><br class=""></div><div class="">Taking your proposal and running with it, I think we could do this:</div><div class=""><br class=""></div><div class="">1 - Specify the feature name with spaces: “Asynchronous Disassembler”</div><div class=""><br class=""></div><div class=""><div class="">2 - On Linux, it gets collapsed and truncated to 15: “AsynchronousDis”</div><div class="">2a - It could get truncated with ellipses: “AsynchronousDi…"&nbsp;</div><div class=""><div class=""><br class=""></div><div class="">3 - On Windows, it gets “WebKit: “ added and is truncated to 30: “WebKit: Asynchronous Disassemb”</div></div><div class="">3a - It could get truncated with ellipses: “WebKit: Asynchronous Disassem…”</div><div class=""><br class=""></div><div class="">4 - On macOS/iOS, it gets “WebKit: “ added: “WebKit: Asynchronous Disassembler"</div></div><div class=""><br class=""></div><div class="">Addendum: If we see value in having somethings flagged as “JSC” instead of “WebKit”, we just augment the input to include that.</div><div class="">The above could be “JSC.Asynchronous Disassembler”, and a WebKit specific feature could be “WebKit. IndexedDB Server”</div><div class=""><br class=""></div><div class="">Thanks,</div>~Brady</div></div>_______________________________________________<br class="">webkit-dev mailing list<br class=""><a href="mailto:webkit-dev@lists.webkit.org" class="">webkit-dev@lists.webkit.org</a><br class="">https://lists.webkit.org/mailman/listinfo/webkit-dev<br class=""></div></blockquote></div><br class=""></body></html>