[jsc-dev] [webkit-dev] Thread naming policy in WebKit

Filip Pizlo fpizlo at apple.com
Thu Jan 5 12:23:22 PST 2017


👍

-Filip


> On Jan 5, 2017, at 10:51 AM, Geoffrey Garen <ggaren at apple.com> wrote:
> 
> Alternatively, we could just change thread name from a char* to a struct { char*, char* } that contains a long name and a short name.
> 
> Geoff
> 
>> On Jan 5, 2017, at 9:37 AM, Brady Eidson <beidson at apple.com <mailto:beidson at apple.com>> wrote:
>> 
>>> 
>>> On Jan 5, 2017, at 12:48 AM, Yusuke SUZUKI <utatane.tea at gmail.com <mailto:utatane.tea at gmail.com>> wrote:
>>> 
>>> On Thu, Jan 5, 2017 at 5:43 PM, Darin Adler <darin at apple.com <mailto:darin at apple.com>> wrote:
>>> I understand the appeal of “org.webkit” and structured names but personally I would prefer to read names that look like titles and are made up of words with spaces, like these:
>>> 
>>> “WebKit: Image Decoder”, rather than “org.webkit.ImageDecoder”.
>>> “WebKit: JavaScript DFG Compiler” rather than “org.webkit.jsc.DFGCompiler”.
>>> 
>>> Not sure how well that would generalize to all the different names.
>>> 
>>> I like the idea of having a smart way of automatically making a shorter name for the platforms that have shorter length limits.
>>> 
>>> One interesting idea I've come up with is that,
>>> 
>>> 1. specifying "org.webkit.ImageDecoder"
>>> 2. In Linux, we just use "ImageDecoder" part.
>>> 3. In macOS port, we automatically convert it to "WebKit: Image Decoder”
>> 
>> Why do we specify “org.webkit.ImageDecoder” if only the “ImageDecoder” part is ever going to be used?
>> Is that because Windows could use “org.webkit.”?
>> 
>> Again, back to Darin’s point, I don’t see any particular value in ever seeing “org.webkit.”
>> 
>> Additionally, the way this proposal treats “ImageDecoder” as multiple words, presumably separated on case-change, is problematic.
>> 
>> e.g. “IndexedDatabaseServer” would expand to “Indexed Database Server”, different from today.
>> e.g. “IndexedDBServer”, which is probably what this should be called, would expand to “Indexed D B Server"
>> e.g. “GCController” would expand to “G C Controller”
>> 
>>>> 
>> Taking your proposal and running with it, I think we could do this:
>> 
>> 1 - Specify the feature name with spaces: “Asynchronous Disassembler”
>> 
>> 2 - On Linux, it gets collapsed and truncated to 15: “AsynchronousDis”
>> 2a - It could get truncated with ellipses: “AsynchronousDi…" 
>> 
>> 3 - On Windows, it gets “WebKit: “ added and is truncated to 30: “WebKit: Asynchronous Disassemb”
>> 3a - It could get truncated with ellipses: “WebKit: Asynchronous Disassem…”
>> 
>> 4 - On macOS/iOS, it gets “WebKit: “ added: “WebKit: Asynchronous Disassembler"
>> 
>> Addendum: If we see value in having somethings flagged as “JSC” instead of “WebKit”, we just augment the input to include that.
>> The above could be “JSC.Asynchronous Disassembler”, and a WebKit specific feature could be “WebKit. IndexedDB Server”
>> 
>> Thanks,
>> ~Brady
>> _______________________________________________
>> webkit-dev mailing list
>> webkit-dev at lists.webkit.org <mailto:webkit-dev at lists.webkit.org>
>> https://lists.webkit.org/mailman/listinfo/webkit-dev <https://lists.webkit.org/mailman/listinfo/webkit-dev>
> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/jsc-dev/attachments/20170105/3033ef23/attachment.html>


More information about the jsc-dev mailing list