<html>
<head>
<base href="https://bugs.webkit.org/">
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - watchOS engineering build is broken after r234227"
href="https://bugs.webkit.org/show_bug.cgi?id=188180#c3">Comment # 3</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - watchOS engineering build is broken after r234227"
href="https://bugs.webkit.org/show_bug.cgi?id=188180">bug 188180</a>
from <span class="vcard"><a class="email" href="mailto:wenson_hsieh@apple.com" title="Wenson Hsieh <wenson_hsieh@apple.com>"> <span class="fn">Wenson Hsieh</span></a>
</span></b>
<pre>(In reply to Wenson Hsieh from <a href="show_bug.cgi?id=188180#c2">comment #2</a>)
<span class="quote">> Hmm, I see now that this is modeled closely after rewrite_headers() in
> postprocess-framework-headers.sh in WebKit, and we also miss setting
> OSX_VERSION and IOS_VERSION there too, because WK_PLATFORM_NAME is
> "watch(os|simulator)".</span >
So in the case where this happens, we end up in a fallback path:
if [[ -n "$OSX_VERSION" && -n "$IOS_VERSION" ]]; then
SED_OPTIONS+=(
-e s/JSC_MAC_TBA/${OSX_VERSION}/g
-e s/JSC_IOS_TBA/${IOS_VERSION}/g
-e s/JSC_MAC_VERSION_TBA/${OSX_VERSION_NUMBER}/g
-e s/JSC_IOS_VERSION_TBA/${IOS_VERSION_NUMBER}/g
-e s/JSC_API_AVAILABLE/API_AVAILABLE/
-e s/JSC_API_DEPRECATED/API_DEPRECATED/
-e "s/^JSC_CLASS_AVAILABLE/JSC_EXTERN API_AVAILABLE/"
-e "s/^JSC_CLASS_DEPRECATED/JSC_EXTERN API_DEPRECATED/"
)
else
SED_OPTIONS+=( -e 's/JSC_(API_|CLASS_)AVAILABLE\(.*\)\s*\)//g' -e 's/JSC_(API_|CLASS_)DEPRECATED(_WITH_REPLACEMENT)?\(.*\)\s*\)//g' )
fi
...which effectively removes all uses of the JSC availability macro. Perhaps this should replace JSC_IOS_VERSION_TBA and JSC_MAC_VERSION_TBA as well with a fallback value of 0?</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>